many clips out of sync in Logic Pro AAF import

More
1 month 1 week ago - 1 month 1 week ago #7938 by James Carrick
James Carrick replied the topic: many clips out of sync in Logic Pro AAF import
Dear Paul,

Thankyou so much for your update. As you can imagine every so often over the years we have looked at Logic but it being part of the Apple family we always assumed they would at some point integrate well with FCPX. That being said it hasn't happened upto this point. Your suggestions are I have to say spot on and well worth investigating further. We will discuss with the Product Manager and development about possible implementation.

Yours Sincerely

James
Last Edit: 1 month 1 week ago by James Carrick.

Please Log in or Create an account to join the conversation.

  • paul skidmore
  • paul skidmore's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 month 1 week ago - 1 month 1 week ago #7937 by paul skidmore
paul skidmore replied the topic: many clips out of sync in Logic Pro AAF import
fearing "there is nothing we can do about it" would be where this might end up*, i did some experimenting.

first, in FCP i duplicated my project, adding "XML prep" to the title, and opened this new timeline. using the Index, i searched for all crossdissolve video transitions (which add audio crossfades automatically), selected them all, and deleted them. then selected my whole timeline in FCP and went to Modify > Adjust Audio Fades... > Remove Fades

this created an AAF with no sync issues.

having the audio fades come over from FCP would be more convenient, but given many of them would be adjusted/re-done in Logic anyway, this is an acceptable workaround for me. others who have experienced this issue might want to know about it, too.

for your reference, i've attached the working FCPXML, and here is the link to the working AAF:


(you may notice i also removed my temp music from the original FCPXML.. i bounced it out of FCP like the reference movie to import as a single AIFF, but this had no bearing on sync issues.)

* i 100% understand this is primarily for ProTools users, and the fact that it works with other audio apps is a bonus, but not necessarily something you support. two questions though:

1) how hard would it be to add a check box for Logic which would trigger stripping the crossfade data out of the XML? this would save Logic users the extra steps of duplicating the timeline and deleting all the fades. a small thing, but over time could be a big deal.

2) and/or if it's something we should address with Logic, where do we go to address that with them and what exactly are we asking for? i feel like if enough people in my position (i've seen at least two other threads about this on the forum) were to correctly articulate the issue to the right engineer at Apple, this is something they might fix. of course, why FCP doesn't inherently export audio to Logic in the first place might be a better place to start.

thank you for your time! even with the workaround, this app is a huge timesaver, especially on my 1h 45m film we're about to do the sound design and score for!
Last Edit: 1 month 1 week ago by James Carrick.

Please Log in or Create an account to join the conversation.

More
1 month 1 week ago #7936 by James Carrick
James Carrick replied the topic: many clips out of sync in Logic Pro AAF import
Hi Paul,

We can compare the FCPXML against the AAF imported into ProTools, if it all looks well, then it is going to be a limitation in the AAF import in LogicPro which there is nothing we can do about.

Will let you know.

Yours Sincerely

James

Please Log in or Create an account to join the conversation.

  • paul skidmore
  • paul skidmore's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
1 month 1 week ago - 1 month 1 week ago #7934 by paul skidmore
paul skidmore created the topic: many clips out of sync in Logic Pro AAF import
i've seen other posts to this effect, but they are several months old.

AAF created in X2Pro imports into Logic Pro, but many clips (certain subroles?) are out of sync. screenshots attached.

if an older version of X2Pro is a workaround, i'd love access to it, please.

i'm using:
M1 13" MacBook Air
macOS Big Sur 11.4 (20F71)
FCP 10.5.4 (Build 400096)
X2Pro Audio Convert 4.5.6
Logic Pro 10.6.3 (Build Version 5458)

XML attached.
link to AAF:



i do get these errors on AAF creation:

Report on conversion from Final Cut XML to AAF

• Unsupported adjustment [loudness] at 00:00:04.79 has been ignored
• Unsupported adjustment [loudness] at 00:00:35.71 has been ignored
• Unsupported adjustment [EQ] at 00:00:04.79 has been ignored
• Unsupported audio filter [Space Designer] at 00:00:04 has been ignored
• Unsupported adjustment [noise reduction] at 00:00:04.79 has been ignored
• Unsupported adjustment [noise reduction] at 00:00:35.71 has been ignored
• Conform rates have not been applied.
• Unsupported adjustment [EQ] at 00:00:35.71 has been ignored
• Some media was not from a WAV file that could be referenced and was instead embedded in the AAF. See Console for details.

X2Pro Audio Convert 4.5.6
Attachments:
Last Edit: 1 month 1 week ago by James Carrick.

Please Log in or Create an account to join the conversation.

Time to create page: 0.158 seconds
Powered by Kunena Forum