Multitrack swapped levels

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
8 years 2 weeks ago #1129 by Graeme Robinson
Graeme Robinson replied the topic: [4641][4642]Multitrack swapped levels
Rui,

As you have not replied in a few days, I'm going to close the internal support ticket (TS4642). If we do get a reply, we will re-open the ticket.

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
8 years 3 weeks ago #1128 by Graeme Robinson
Graeme Robinson replied the topic: [4641][4642]Multitrack swapped levels
Rui,

Were you able to look into this yet?

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
8 years 1 month ago - 8 years 1 month ago #1120 by Graeme Robinson
Graeme Robinson replied the topic: [4641][4642]Multitrack swapped levels
The audio tracks getting "switched" in Pro Tools looks like it's a bug. I have create a bug report in our system for this.

If you let me know whether the volume is applied to the right audio tracks, but they are arranged in the wrong order in the AAF, we can move forward on that issue.
Last Edit: 8 years 1 month ago by Graeme Robinson.

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
8 years 1 month ago - 8 years 1 month ago #1119 by Graeme Robinson
Graeme Robinson replied the topic: Multitrack swapped levels
The errors were a bit cryptic:

Attachment FCPXErrorscreengrab.png not found


and resulted in a sequence with black clip placeholders (instead of red media offline ones) with no option to expand audio components:

Attachment BlackPlaceholders.png not found



I think I've figured out that it was caused by the fcpxml referring to files without a file extension, which my copy of FCP X didn't like:
There is one file path with a file extension, (/Volumes/ABRI FCP/FCPX archives/FCPX 10.1/presets/1000Hz-12dB_1-2.aif) but the other 6 file paths have no extension (/Volumes/ABRI FCP/ABRI_MEDIA/Capture Scratch/ Nouveau_SON/20130411_NS/ABRI2240_NS). I edited the fcpxml and added file extensions to these 6 file paths (I added ".mov") and then FCP X would import the FCPXML without any errors, and it enabled me to see the audio components.

Is there something strange about these clips? What type of file are they?

I can see the the audio levels being applied to tracks 5 & 6 in the AAF, when they were on the 2nd and 3rd tracks in FCP. Furthermore, I can see that automation gain has been applied to the end of track 5 in the AAF, where the audio from track 2 in FCP ended early (you mentioned this effect in the 4th paragraph of your last post).

Looking again at the fcpxml, the audio tracks are described in the order: 1, 5, 6, 7, 8, 9, 10, 11, 12, 2, 3, 4 with the volume adjustments made to tracks 5 & 6. This would appear in FCP as if the the audio adustments had been made to tracks 2 & 3 (visually). Can you check whether the audio from tracks 2 & 3 in FCP is the same audio as on tracks 5 & 6 in Pro Tools (i.e. the volume has been applied to the right track, but the track order in Pro Tools looks wrong)?

I also see the audio getting "switched" that you mention and I will speak to the developers about this. Right now, I can't think of an easy workaround for this.
Attachments:
Last Edit: 8 years 1 month ago by Graeme Robinson.

Please Log in or Create an account to join the conversation.

  • Rucap
  • Rucap's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 1 month ago #1116 by Rucap
Rucap replied the topic: Multitrack swapped levels
I import the same fcpxml, as you suggested, and all the information is there, no error message. None of its contents is lost.

Also, at 00:00:32:17 on audio clip ABRI0206_NS I have the audio levels you mentioned but on the right tracks A2-A3, level +10dB (as on the original FCPX project) instead of the A5-A6. So the level swapping is still there.

The errors you got on import were to relink the original video shots, right? as well as a timecode generator...

I have other audio effects on the 12 audio track that are 'glued' to the video, like a deactivate part, on A2 that starts at 00:00:58:21 until the end of audio - only on that track. Could be this sort of audio effects that ruins the levels export for the AAF export? This is not severe as our mixing guys will remove all levels;

Our major problem for them is that our alternating 12 audio tracks/12 audio tracks, gets switched (on the export to AAF). Example: at 00:00:00:00 (orange outline on the image) and 00:00:12:17 (green outline on the image) requiring much more knitting on ProTools.
Link to image: we.tl/ad4xeXDddw

What is this problem, as this is what ends up ruining our audio post that was well prepared in advance to have 12 tracks joined for each bit of sound used?

Thanks once again!

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
8 years 1 month ago #1114 by Graeme Robinson
Graeme Robinson replied the topic: Multitrack swapped levels
  1. I meant that I couldn't import the XML in FCP X properly to look at the audio levels. It was nothing to do with X2Pro. FCP X gave me an error message when I tried to import it.
    When exporting the fcpxmls, it doesn't matter what "metadata view" you choose. X2Pro will convert fcpxnls that have any metadata included ("Basic", "General", "Extended", "Audio", etc all work.)
  2. I mean that if you have 3 clips with a role of "dialog" and 3 with a role of "music", X2Pro will put all the clips with the "dialog" role on one set of tracks, and all the clips with the "music" role on another set of tracks. The tracks in Pro Tools will be labelled with whatever roles were used in the fcpxml.

Please Log in or Create an account to join the conversation.

  • Rucap
  • Rucap's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 1 month ago #1112 by Rucap
Rucap replied the topic: Multitrack swapped levels
thank you for looking at it, Graeme.

Thank for pointing out that could be the fcpxml where the problem is. Will check this to get back to you.

Just to making it clear, what do you mean there were errors on import and quite a bit of information seems to be lost? Should the fcpxml be exported using other options like "General", "Intermediary" other than "Audio"? Or is that irrelevant?

And also, what do you mean consider using roles in FCP X. X2Pro will use certain tracks in the AAF for clips with specific roles? X2Pro will make a clear separation of audio clip roles, alternating the tracks of one role first, and only below these tracks creating an alternation of another role?

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
8 years 1 month ago #1111 by Graeme Robinson
Graeme Robinson replied the topic: Multitrack swapped levels
Hi Rui,

I tried importing your fcpxml into FCP X, but there were errors on import and quite a bit of information seems to be lost.

I did however find a section in the fcpxml describing a clip called ABRI0206_NS starting at 00:00:32:17 and describing audio tracks 5 & 6 as having a 10dB volume adjustment.

Can you check whether when you import the fcpxml, you get the same results as in the AAF. If you do, then the problem is with the fcpxml.



If you want to have some control over the order of audio tracks in your AAF, consider using roles in FCP X. X2Pro will use certain tracks in the AAF for clips with specific roles.

Please Log in or Create an account to join the conversation.

  • Rucap
  • Rucap's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 1 month ago - 8 years 1 month ago #1109 by Rucap
Rucap created the topic: Multitrack swapped levels
Hi Graeme, I've been testing a project export from fcpxml to AAf for a feature film.

As I've already done a few tests already the sound guys seem to note that our 12 audio multitrack clips seem to be changing the audio levels from channel A2-A3 to A5-A6.

As we are trying to get the audio with the minimal errors possible to save preparation work on ProTools, can you tell us what might seem to be the problem.

I have a AAF test available and an fcpxml if you care to take a look at it. On the image the swapped levels are signaled orange on tracks 5-6, they should be on tracks 2-3.

we.tl/lXB2C8OOpk

Another issue that we cannot yet understand is that fcpxml or X2Pro split our 12 track, as we wanted to keep them always 12 tracks, 12 tracks, alternating in order to have all our mikes and camera sound always on the same channels, thus prepared for mixing. Somehow it still makes some splitting rearranging tracks, how can we solve this with X2Pro?

Thank you and best regards!
Last Edit: 8 years 1 month ago by Rucap. Reason: adding track slipping issue

Please Log in or Create an account to join the conversation.

Time to create page: 0.062 seconds
Powered by Kunena Forum