XML file won't parse out of FCPX 10.1.3 - Ideas?

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
9 years 7 months ago #1419 by Graeme Robinson
Graeme Robinson replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
That error doesn't look like it's caused by the same thing, though it is similar.

Thanks for posting the workaround that worked for you.

Please Log in or Create an account to join the conversation.

More
9 years 7 months ago #1414 by geoffreyo
geoffreyo replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
I got a similar error today, not sure what the problem is. Screenshot attached.

I couldn't figure out where the problem was or how to fix it, but I did find a work around:
  • - Select your Project in the Browser
  • - File>Copy Project to Library> (I would suggest creating a new library just for this).
  • - Select the new copy of the project in the new Library and Export the XML.

Not sure if that will work for you, but it created a clean XML for me that X2Pro parsed fine and translated to an AAF without any further problems.

–––––––––––––––––––––––––––––––
Geoffrey Orthwein
BOKEH • Zealous Pictures
www.facebook.com/bokehmovie         www.bokehthemovie.com
Attachments:

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
9 years 8 months ago #1355 by Graeme Robinson
Graeme Robinson replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
The fcpxml that you attached is not valid xml. If you try to re-import that fcpxml into FCP X, it gives a very similar error to the one that X2Pro reports.

The problem is that it contains a marker with an invalid (unprintable) character . The marker is called "≤." (the "." has been substituted for the unprintable character because it can't be displayed). You can see the marker for yourself if you open the fpcxml in TextEdit and search for "≤" (without the quotes).

The fcpxml says that it is supposed to be at 14397.717 seconds from the start of the sequence (about 03:59:57:18) which seems odd as your sequence isn't anywhere close to that duration. Anyway, I have replaced the invalid character with a space (" ") in your fcpxml and X2Pro seems happy to convert it.

I have attached the edited fcpxml. Let me know whether you are able to convert it ok using this one.
Attachments:

Please Log in or Create an account to join the conversation.

  • kburget
  • kburget's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
9 years 8 months ago #1352 by kburget
kburget replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
And what I assume is latest version of X2Pro - 2.3

Please Log in or Create an account to join the conversation.

  • kburget
  • kburget's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
9 years 8 months ago #1351 by kburget
kburget replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
I'm on FCPX 10.1.3 and OSX 10.9.5

Please Log in or Create an account to join the conversation.

  • kburget
  • kburget's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
9 years 8 months ago #1350 by kburget
kburget replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
I read in another message that you like the error message text cut and pasted. Here goes:

Unable to parse FCP XML file to obtain project information

Details:
Unable to parse file /Users/kevinburget/Desktop/AAI 2014 Fine 7.fcpxml (Line 1055: invalid character in attribute value
Line 1055: attributes construct error
Line 1055: Couldn't find end of Start Tag marker
)

Suggestions:
- Ensure that the file is not locked by another application and is readable;
- Ensure that this is a valid FCP XML file from a released version of FCP X;
- Ensure that this is the export of a Project, not of an Event;
- Ensure that this is not an empty project (or that all audio is disabled);

Please Log in or Create an account to join the conversation.

  • kburget
  • kburget's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
9 years 8 months ago #1349 by kburget
kburget replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
Any thoughts? I'm up against a huge deadline. I've been using X2Pro for a few years now, never encountered this.

Please Log in or Create an account to join the conversation.

  • kburget
  • kburget's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
9 years 8 months ago #1348 by kburget
kburget replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
Error message attached. thx
Attachments:

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
9 years 8 months ago #1347 by Graeme Robinson
Graeme Robinson replied the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
Please copy/paste any warnings/errors that X2Pro is displaying

Please Log in or Create an account to join the conversation.

  • kburget
  • kburget's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
9 years 8 months ago #1346 by kburget
kburget created the topic: XML file won't parse out of FCPX 10.1.3 - Ideas?
I've attached the xml. No idea why this isn't working...
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.081 seconds
Powered by Kunena Forum