XDCAM HD422 and "Invalid Track Layout for Asset"

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
3 years 8 months ago #2416 by Graeme Robinson
Graeme Robinson replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
I can't find anything wrong with that file, and I can convert projects that use it here. It appears to be used on an inactive angle of a multicam clip. Are you able to just remove that angle from the project if it's not being used?

The multicam clip is at 10:01:03:10 and is called "Final prep draw order 10" and the angle that uses this clip is called "XF". Perhaps if you removed the whole XF angle from that multicam clip, that might let you work around the error.

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 8 months ago #2408 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
Hey X2Pro peeps,
Any progress on the file I uploaded?

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 8 months ago #2315 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
Contact info sent.

Please Log in or Create an account to join the conversation.

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
3 years 8 months ago #2313 by Jeremy Norwood
Jeremy Norwood replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
If you will send me your contact details to This email address is being protected from spambots. You need JavaScript enabled to view it., I can provide you our FTP information.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 8 months ago - 3 years 8 months ago #2312 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"

I got an error when importing the XML to FCPX (see screenshot attached) but it imports and looks all right.

And I got the same error as before when trying to Export from X2Pro.

What's the easiest way to get you that mxf file? It's just over 2GB. Dropbox?

Thanks
Attachments:
Last Edit: 3 years 8 months ago by slickslack.

Please Log in or Create an account to join the conversation.

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
3 years 8 months ago #2311 by Jeremy Norwood
Jeremy Norwood replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
So it is.

Try using the attached XML and see if it works for you.
If not, we may need to get the file "AA848301.mxf" from you.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]
Attachments:

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 8 months ago #2310 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
It is at 2.5.1
I would hazard a guess that the file itself is what is causing this, not the XML. I can try to send you a video file of the sort that seems to be causing this.
Attachments:

Please Log in or Create an account to join the conversation.

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
3 years 8 months ago - 3 years 8 months ago #2309 by Jeremy Norwood
Jeremy Norwood replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
Are you running the latest released version of X2Pro from the App store?
The latest version is 2.5.1.

Check your X2Pro version and update it if possible.

I tried converting your XML and it converts for me.

Please let us know how you get along.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]
Last Edit: 3 years 8 months ago by Jeremy Norwood.

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 8 months ago #2307 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
Alright, I'm back in front of this project.
The text of the X2Pro Error is:

Invalid track layout for asset AA848301

No AAF file has been generated.


File Attachment:

File Name: X2Pro_Test003.fcpxml
File Size:458 KB
Attachments:

Please Log in or Create an account to join the conversation.

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
3 years 9 months ago - 3 years 9 months ago #2240 by Jeremy Norwood
Jeremy Norwood replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
When you get back to the project and still get an error if you can send me the FCP XML and the full text from the X2Pro error that you get, it will definitely help expedite the process.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]
Last Edit: 3 years 9 months ago by Jeremy Norwood.

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 9 months ago #2238 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
Phew, I was beginning to think I'd been forgotten.
I am not currently in front of that project right now and I won't be for a couple of weeks.

If I remember correctly the project I sent you was the one that generated the error message. I will see what I can do about making a small subsample of that media and getting you that library and a test project. (Forgive me if I get my terms mixed up, I am in the middle of a Premiere project set up)

If we can get this to work we'll be getting the upgrade to the full version as we have to push the project through a ProTools finish. I just can't get the $$people to sign off until this workflow has been verified.

Please Log in or Create an account to join the conversation.

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
3 years 9 months ago #2237 by Jeremy Norwood
Jeremy Norwood replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
My apologies for the extremely delayed response.
I tried converting your FCPXML that you did give us, and it is working on my computer; and I believe you said you did get it working there.

In general, X2Pro does support converting projects that contain mxf files. In fact, the fcpxml that you gave us does convert even though it uses 13 mxf files.
If you are still see or are getting an error message of "Invalid track layout", then we will need to get an fcpxml from you that produces that error.

In regards to the differences between X2Pro and X2Pro LE, the comparison chart can be found here .
To summarize, X2ProLE is a lower cost version for those who do not need the advanced professional functions of referenced media, trimmed media, or close control of the conversion of roles.

Again, my apologies for the delay.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 9 months ago #2231 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
Hey there X2Pro-ers,
Any progress here?
Trying to manage expectations on how our post flow might work. It would be great to know if there's any progress or more information on this issue and whether we need to look elsewhere.

Thanks
slickslack

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 9 months ago - 3 years 9 months ago #2222 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
The "sequence" you mean? We're using test sequences as we're in the early stages of cutting.
I hope this is what you mean by configured media locations. Let me know if it's not and I'll get what you need.

Thanks


EDIT: I got an error message saying that the XML was empty so it wouldn't upload.
EDIT2: Re-exported and this time it worked.
Attachments:
Last Edit: 3 years 9 months ago by slickslack. Reason: noted 2

Please Log in or Create an account to join the conversation.

  • slickslack
  • slickslack's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 years 9 months ago #2220 by slickslack
slickslack replied the topic: XDCAM HD422 and "Invalid Track Layout for Asset"
So I am gathering from the silence, that clips that were dragged into FCP X as XDCAM HD MXFs which play fine and can be synched in multi cams etc. CANNOT be exported using X2Pro. If this is something that is different for the Pro version vs the LE version, which I don't believe it is, that would be good to know.

I did some more tests today and converted some of the XDCAM to ProRes and relinked it from inside FCPX and the X2PRo exported those with well, not ease, but it eventually did make an AAF. I got a message saying some materiel "had to be modified something something something shot at 24 but edited at 23.976" or some such text.

However when I brought the AAF into Logic X the only audio that was in it was the stuff that had been converted to ProRes from the MXF. The other source in the multicam that I used for the test was from RED and that footage was native and none of that material showed up in the AAF.

It looks like because of the way this project was started that X2Pro will not be an option and we're looking at dumping out full length AIFF/WAV split up by roles. The other option is to slowly convert all the MXF stuff and somehow relink each library to the ProRes version of each file.

Please Log in or Create an account to join the conversation.

Time to create page: 0.398 seconds
Powered by Kunena Forum