XML problems

More
2 years 2 months ago #5169 by James Carrick
James Carrick replied the topic: XML problems
Hi Dan,

We have just released 4.0.17 can you please retry as this should resolve the issue.

Yours Sincerely

James

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
2 years 2 months ago #5122 by Graeme Robinson
Graeme Robinson replied the topic: XML problems
Hi Dan,

I'm sorry, this is my fault; I updated https://fixfcpxml.appspot.com/ to be more memory efficient, but in doing so, I broke it in a way that means it didn't fix fcpxmls as thoroughly as it used to.

I have reverted those changes, and it should now fix your fcpxml so that X2Pro will be able to process them.

The next version of X2Pro should not require you to use this service, but until then, it should work.

Sorry again...

Please Log in or Create an account to join the conversation.

  • dan
  • dan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 years 2 months ago #5117 by dan
dan replied the topic: XML problems
Hi - so I figured out by process of elimination....again, it's MXF's that are causing a problem.
Your software does not seem to be able to deal with MXF's properly.
The clips causing the crash were still linked t original camera audio in the MXF. Once I linked them to 3rd party record, the XML exported fine and did not crash.
I've attached the updated XML for you to problem solve this.
Luckily I do not need the camera audio, but I can tell you 1000% there are times when I do and I wont be able to make AAF's currently with your software because of this.
Attachments:

Please Log in or Create an account to join the conversation.

  • dan
  • dan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 years 2 months ago #5110 by dan
dan replied the topic: XML problems
I attempted to clean up MXF's making sure all files were linked to audio multitracks.
The 5 second worked no problem, the 60 second crashes the app everytime.
Logic Pro has no problem opening the XML's and showing all tracks.
I've attached the updated XML that crashes the app.
Attachments:

Please Log in or Create an account to join the conversation.

  • dan
  • dan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
2 years 2 months ago #5109 by dan
dan created the topic: XML problems
HI, was getting xml's that crashed X2pro, followed another post and got the 'fixed' version.
Worked for one XML, sort of, got an error about 'could not read' due to MXF's.
On the 2nd XML, it says it cannot parse the XML....
One is a 5 sec ad and the other is a 60 second ad.
I've attached the files.
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.053 seconds
Powered by Kunena Forum