No audio tracks defined in asset xx

  • robmaas
  • robmaas's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
3 months 2 weeks ago #6237 by robmaas
robmaas replied the topic: No audio tracks defined in asset xx
I got it to work with the help from RobC, however I now have a massive file size issues and the app still doesn't work for me. And on a tight deadline. Shame there aren't any competitive apps in the market.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #6236 by louisbastin
louisbastin replied the topic: No audio tracks defined in asset xx
I just bought X2pro, full price and I have the same msg.
Is there a way to make it work ?
Or to be refunded ?
I bought it for a precise usage, if I cant reuse it, pls rfund.
Yours.

Please Log in or Create an account to join the conversation.

  • robmaas
  • robmaas's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
3 months 2 weeks ago #6231 by robmaas
robmaas replied the topic: No audio tracks defined in asset xx
Got also an AAF from X2Pro, however the file size is 40gb for a 90 minute film, that's a lot. Also I only can embed, not create separate files. Is that normal behavior?

Please Log in or Create an account to join the conversation.

  • robmaas
  • robmaas's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
3 months 3 weeks ago #6211 by robmaas
robmaas replied the topic: No audio tracks defined in asset xx
Thanks for this. I tried the suggested workarounds, unfortunately none of them did work yet and it reported the same problems. Also after breaking apart video from audio in FCPX. The workaround that did work for me so far:
- Export FCPxml from FCPX
- Converted FCPxml to xml with XtoCC
- Imported the converted xml into Premiere
- Exported AAF from Premiere or go first through Audition and export OMF

In this workflow X2Pro is skipped, but I really hope the problem gets fixed soon.

Thanks,
Rob
The following user(s) said Thank You: Daniel Beasley

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #6202 by James Carrick
James Carrick replied the topic: No audio tracks defined in asset xx
Dear RobC,

Many thanks

Dear RobM,
In your XML we see for asset r7 that it is only video,

<asset id="r7" name="A002C003_160622_R07R" uid="7846BA1271B85E6D248D4B620AC75483" src="file:///Volumes/acht_bup_01/deachtstedag/1_source/20160622/schijf%202/A002R07R/A002C003_160622_R07R.mov" start="1318248/25s" duration="50067/25s" hasVideo="1" format="r1" customLogOverride="ARRI_LogC_3DLUT">

If you look at asset r10 for example you can see it has audio and details what the audio is.

<asset id="r10" name="The Birth Mix corr Stereo-AIFF 48:16" uid="572CA101ED02B05724ACF808E182A27C" src="file:///Volumes/acht_bup_03/ralf/Voor%20Generale/Audio/Muziek/bisceglia%20-%206-11/The%20Birth%20Mix%20corr%20Stereo-AIFF%2048:16.aiff" start="0s" duration="19776009/48000s" hasAudio="1" audioSources="1" audioChannels="2" audioRate="48000">

When we look past the asset section and look at the structure of project we see that r7 has audio referenced in several locations.

<audio lane="-1" offset="1318248/25s" ref="r7" duration="50067/25s" start="1318248/25s" role="dialogue.dialogue-1" srcCh="1, 2"/>

It is this that causes us to bail on AAF creation, i.e. asset without audio, shows in the project as having audio.

If possible, if you are able to supply the essence we can push through here to create an AAF for you, because the XML we modified using fixfcpxml does go through here.

Please advise.

Yours sincerely

James

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #6199 by RobC
RobC replied the topic: No audio tracks defined in asset xx
I stand corrected, but to me it seems the fcpxml defines that certain videoclips do have audio assets, but there actually is no assets or media referenced. X2Pro is looking for the audio assets, but there is/are no audio assets.

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #6198 by RobC
RobC replied the topic: No audio tracks defined in asset xx
I ran in the same problems. There are ghost clips attached to the videoclips which cause the trouble. In the attachment I outlined a possible solution that worked for me.

While I was waiting for a confirmation email I thought of another possible solution:


If you only have one storyline, the primary storyline, there is probably an easier way to make the xml work and not get the error No audio tracks defined in asset [xxx.xxx]

1 Select all clips in the primary story line and do: Break Apart Clip Items
2 Select all videoclips in de primary story line and move them up (alt-cmd-arrow up) They become a secondary storyline of video-only clips.
3 Delete the secondary storylines so you end up with an audio-only project.
4 export an xml from your project.

Then the xml should work fine from the first time.

If you have a project with secondary storylines, you could lower them first in the primary storyline and then follow the previous steps: get rid of the videoclips once they were synchronized. They (can) cause the problem.

Hope this Helps
Rob
Attachments:

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #6197 by James Carrick
James Carrick replied the topic: No audio tracks defined in asset xx
Dear Rob,

Fundamentally the issue is a bug in FCPX, in that the XML generated somehow defines the media as having no audio channels but then references audio channels for that media. The app that was put together was to look through an FCPX XML and where ever it saw media that was defined as having no audio but did actually reference audio channels later on it would modify the definition of the media to say it has X, or Y channels of audio.

As I understand it we processed your XML through the fixfcp app, we were then able to process the XML here.

If we can process your XML here after going through the app, then there is nothing wrong with this modified XML, if you cannot process the same XML your end, then we really need the actual media essence, is this something that you would or could be able to provide ?

Please advise.

Yours sincerely

James

As such if you are still getting an error

Please Log in or Create an account to join the conversation.

  • robmaas
  • robmaas's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
3 months 4 weeks ago #6196 by robmaas
robmaas replied the topic: No audio tracks defined in asset xx
No it doesn't work, tried the same edits and also tested your fixed fcpxml and I get the same exact result on the exact same clip. The fixfcpxml app also gives an error. I can't spend time debugging your app. So, this doesn't help. Please guide me forward asap.

Please Log in or Create an account to join the conversation.

More
4 months 1 day ago #6195 by Daniel Beasley
Daniel Beasley replied the topic: No audio tracks defined in asset xx
Hi Rob,

This is a problem with how FCP X creates some xml files.Your XML describes some assets as having no audio, but then it tries to reference the assets audio later on and then discovers it cant find any and then returns an error.

Trying to put your xml through X2Pro I get the error "No audio tracks defined in asset [A002C003_160622_R07R]"
If I open your xml in TextEdit and search for "A002C003_160622_R07" I can see it relates to asset id="r7". This contains information about that asset.

The problem is your other assets contain details about audio "audioChannels=" "audiosources=" "hasaudio=" but for some reason this one doesn't.

The way that we currently working around this FCP X issue is by editing the xml using: https://fixfcpxml.appspot.com/ which will search for any assets which don't contain any details about audio and it will create some, which should then allow X2Pro to create the AAF.

Once I had put your xml through the fix and then X2Pro, it didn't display the error. I have attached a new version of your xml which should hopefully not contain a problem.

I hope this helps,

Regards,

Daniel
Attachments:

Please Log in or Create an account to join the conversation.

  • robmaas
  • robmaas's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
4 months 1 day ago - 4 months 1 day ago #6194 by robmaas
robmaas replied the topic: No audio tracks defined in asset xx
So I can reconstruct this:
When export the FCPXml via XtoCC and importing into Premiere I see some clips are offline, which I think are the sames ones causing the problems in X2Pro. Those clips are online in FCPX, perhaps this might help you coming up with a fix for the problem. I believe I can see now in Premiere which clips are causing the problems.
Last Edit: 4 months 1 day ago by robmaas.

Please Log in or Create an account to join the conversation.

  • robmaas
  • robmaas's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
More
4 months 1 day ago #6193 by robmaas
robmaas created the topic: No audio tracks defined in asset xx
I'm running into the same errors with X2Pro:
No audio tracks defined in asset xx

I tried manually fixing the FCPXml but with no luck so far. Can you please explain the core of this problem and also guide me through the process of fixing the FCPXml. It is just very time costly and for me X2Pro yet didn't work on one single occasion. I'm afraid fixing on err will bring up another err.
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.101 seconds
Powered by Kunena Forum