Help X2pro Unable to parse FCP XML file

  • nicobier
  • nicobier's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 week ago #7329 by nicobier
nicobier replied the topic: Help X2pro Unable to parse FCP XML file
Hi James,

I finally found a solution half way...

- I edited the XML in BBedit to solve the error FCPX was giving me.
- FPCX was taking but X2pro was still problematic..
- I simply reimported the XML in FCPX and Re-exported... Somehow it solved the problem.

thank you for your help. Take care
The following user(s) said Thank You: Daniel Beasley

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #7326 by James Carrick
James Carrick replied the topic: Help X2pro Unable to parse FCP XML file
Dear Nicobier,

Apologies but we have tried to hand modify the XML but have been unsuccessful, this is not entirely unexpected as FCPXML are notoriously difficult to modify by hand. You will need to open up the project in FCPX and look for audio clips that you have named "cam b". In your XML the issue appears to be clips that have been named cam b but have an illegal character after the "b", so you will need to manually rename these clips in FCPX to remove the illegal character, before generating another XML export from FCPX.

Yours sincerely

James

Please Log in or Create an account to join the conversation.

  • nicobier
  • nicobier's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 week ago #7318 by nicobier
nicobier replied the topic: Help X2pro Unable to parse FCP XML file
Dead James,

I have the same issue wit this 2 xml. It appears it is related to a keyword that I erased.
can you please help me modify them as well?

Thank you very much for your help.
Attachments:

Please Log in or Create an account to join the conversation.

  • nicobier
  • nicobier's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 week ago #7317 by nicobier
nicobier replied the topic: Help X2pro Unable to parse FCP XML file
thank you. That would be great.

Nico

Please Log in or Create an account to join the conversation.

  • nicobier
  • nicobier's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 week ago #7316 by nicobier
nicobier replied the topic: Help X2pro Unable to parse FCP XML file
I tried to divide the project in reel.
I manage to ecreate and AAF of the first reel but the 2nd is showing the same error.
Attachments:

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #7315 by James Carrick
James Carrick replied the topic: Help X2pro Unable to parse FCP XML file
Dear Nicobier,

If we try and import the xml back into FCP we get the attached error. We can look to see if we can modify your xml so that it can be re-imported.

Yours sincerely

James
Attachments:

Please Log in or Create an account to join the conversation.

  • nicobier
  • nicobier's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 week ago #7314 by nicobier
nicobier replied the topic: Help X2pro Unable to parse FCP XML file
Yes, there it is.
I am working on Final cut Pro x 10.4.8

Thank you.
Attachments:

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #7313 by James Carrick
James Carrick replied the topic: Help X2pro Unable to parse FCP XML file
Dear Nicobier,

What generated the FCPXML's ? Are you able to attach the V1.8 XML so we can take a look at it ?

Thanks.

James

Please Log in or Create an account to join the conversation.

  • nicobier
  • nicobier's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 1 week ago #7312 by nicobier
nicobier created the topic: Help X2pro Unable to parse FCP XML file
Hi,

I just released an FCPXML 1.7 and 1.8, both doesn't work the same error message.
I checked the computer console.

I have not a clue of what I can do in this case...
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.098 seconds
Powered by Kunena Forum