Wrong roles

More
3 months 4 weeks ago #7931 by James Carrick
James Carrick replied the topic: Wrong roles in ref-clips
Dear PonPon

Within FCP X, it is possible to create "compound-clips" (in effect sections of sequences) that can be used repeatedly on other sequences. In general, these are used for short sections that appear repeatedly in the final sequence. The advantage of using these compound-clips is that if you decide you need to change the content, you do so just once and all uses of the compound-clip reflect the change. This is in contrast to just copying a section into the sequence, which makes a unique copy which is unrelated to any other copies you may have made on the same sequence.

Within the FCP XML, these compound-clips are referred to as ref-clips and the timeline data appears early on in the file in the resources section. Each compound-clip will appear only once in the resources section, regardless of how many times it appears on the final sequence.

Because the sequence data is now split, part appearing as part of the project (sequence) and part appearing within the resources section, it is problematic to process these ref-clips i.e. which settings applied in the main project should or should not be applied to the compound clip. We have raised as ticket 9539 here, because we see we are processing the sub-roles correctly according to the project settings but this is not what you actually see in FCPX.

The project you sent is all one compound-clip. That is to say that the entire sequence has been saved as a compound-clip and then added in its entirety to a new sequence. Do you know why this might have been done ? Would you be able to un-wrap the compound clip your end ?

Many Thanks

James

Please Log in or Create an account to join the conversation.

  • Ponpon
  • Ponpon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 4 weeks ago - 3 months 4 weeks ago #7930 by Ponpon
Ponpon replied the topic: Wrong roles
what do you mean by ref-clip ?
I don't understand why in the same project one clip don't have subrole and the others have no problem.
Last Edit: 3 months 4 weeks ago by Ponpon.

Please Log in or Create an account to join the conversation.

More
3 months 4 weeks ago #7929 by James Carrick
James Carrick replied the topic: Wrong roles
Hi PonPon,

To confirm the entire project is a ref-clip. The ref-clip does not have the useAudioSubroles attribute so in its absence it defaults to 'no'. This means that sub-roles beneath it are discarded. As far as we can determine we are correctly processing the XML.

Yours sincerely

James

Please Log in or Create an account to join the conversation.

More
5 months 1 day ago #7907 by Daniel Beasley
Daniel Beasley replied the topic: Wrong roles
He has looked at your xml and found that there is a setting on the compound clip which is telling us to merge the roles together. Have you used any other tools on the fcpxml? Did you change any settings on the compound clip?

Please Log in or Create an account to join the conversation.

  • Ponpon
  • Ponpon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 months 1 day ago #7906 by Ponpon
Ponpon replied the topic: Wrong roles
No news from developers ?

Please Log in or Create an account to join the conversation.

More
5 months 3 days ago #7904 by Daniel Beasley
Daniel Beasley replied the topic: Wrong roles
Hi Ponpon,

We have managed to reproduce the issue here and I have passed it onto one of our developers to take a look at to see why this is happening. I will let you know when we have a solution tomorrow.

Please Log in or Create an account to join the conversation.

  • Ponpon
  • Ponpon's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 months 3 days ago - 5 months 3 days ago #7903 by Ponpon
Ponpon created the topic: Wrong roles
I need to export my 52' documentary for post-audio.
I use FCPX 10.4.6 and X2Pro 4.5.4
Preferences Keep Subrole separate

When I open my fcpxml in X2Pro, it use 2 roles i haven't in my sequence.
In FCPX i use : 011_Dial_Chris_Perche and 012_Dial_Chris_Cam
In X2Pro that give me : 01_Dial_Chris (whithout the subrole)

I join the fcpxml and screen capture of the sequence

I need to finish a clean export tomorrow, please help !
Attachments:
Last Edit: 5 months 3 days ago by Ponpon.

Please Log in or Create an account to join the conversation.

Time to create page: 0.163 seconds
Powered by Kunena Forum