X2Pro + Worx4 fail with current FCP XML versions

More
3 months 1 week ago #8133 by Daniel Beasley
Daniel Beasley replied the topic: X2Pro + Worx4 fail with current FCP XML versions
Hi Ide,

We have now resolved the issue with Worx4 X so it will no longer crash when dropping your xml files into it. This fix will be available in the next update via the Appstore, but if you wish to have it sooner we can provide you a temporary version until it comes out.

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #8127 by James Carrick
James Carrick replied the topic: X2Pro + Worx4 fail with current FCP XML versions
Dear Ide3308

As Tim and Daniel have said the issue is the XML/MLD. Fundamentally if the XML/MLD cannot be re-imported back into FCPX then their is a problem with it. Worx4x should not have crashed, the reason it crashed was because we never expected for their not to be a duration in the element section and so it fell over, we will definitely look at addressing this in the Worx4x code.

Regarding the MLD, can we ask how this was originally created, was it processed by any other service before being used in FCPX ?

Yours Sincerely

James

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #8126 by TimRobson
TimRobson replied the topic: X2Pro + Worx4 fail with current FCP XML versions
The problem is that the XMLs were invalid, they had missing elements which makes them unreadable. To confirm this create a new project and try to re-import the xml into FCPX. If it doesn't reimport then the problem is with FCPX and unfortunately you'll need to contact Apple.
In previous cases where X2Pro has been unable to open XMLs with this error FCP has been unable to reimport them.

Please Log in or Create an account to join the conversation.

  • ide3308
  • ide3308's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 2 weeks ago #8125 by ide3308
ide3308 replied the topic: X2Pro + Worx4 fail with current FCP XML versions
Hi there... This solution doesn't really work for us as every piece of audio is critical to the final mix. Either way, this is not the only issue we are having... Please see attached screen recording (no audio), showing up X2Pro exhibits unexpected behavior. The main timeline doesn't export, so I try a short version which also doesn't work. As a test, I removed some music files, and the export worked. Removing those same offending clips from the main timeline still creates an error. Again, I'm using the Share Destination set to X2Pro, and it still fails. Creating XMLs via the separate menu also doesn't work. I've tried many combinations of Metadata views with both v1.9 and v1.10 XMLs. All files are online and accessible to both FCP and X2Pro (thru sandbox).

What is our workaround?
Attachments:

Please Log in or Create an account to join the conversation.

More
3 months 2 weeks ago #8122 by Daniel Beasley
Daniel Beasley replied the topic: X2Pro + Worx4 fail with current FCP XML versions
Hi ide,

It looks like the xmls that were created by FCPX are 'invalid' for some reason. It seems to be missing a key part of the xml for a specific clip which doesnt show where to find that file. It looks to be related to a clip " FX6_C030_110521-00005" if you can remove anything related to this clip X2Pro should then be able to generate you an AAF file.

Please Log in or Create an account to join the conversation.

  • ide3308
  • ide3308's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 3 weeks ago #8119 by ide3308
ide3308 replied the topic: X2Pro + Worx4 fail with current FCP XML versions
Hi, checking in on this. I managed some exports but still critical portions of our show are not exporting. Tried:

Slug (no video) w/ only audio clips
Reference video w/ audio clips
Original timeline w/out Compound Clips

"Unable to parse FCP XML..."

Tried different XML destinations, using the Share Destination direct to X2Pro, exporting v1.10 AND v1.9 XML to various locations. There is no rhyme or reason to what will cause this to fail. One act exports perfectly from X2Pro, and the very next fails w/ Parse error. Please advise...

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #8118 by Daniel Beasley
Daniel Beasley replied the topic: X2Pro + Worx4 fail with current FCP XML versions
Hi ide,

I have passed your xmls back to one of the developers to investigate what might be the issue with them.

Please Log in or Create an account to join the conversation.

  • ide3308
  • ide3308's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 3 weeks ago #8113 by ide3308
ide3308 replied the topic: X2Pro + Worx4 fail with current FCP XML versions
Thank for your quick response. I downloaded both apps from the Mac App Store this morning. I attached the FCP XML directly, but had to attach the FCPXMLD as a zipped file.
Attachments:

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #8112 by TimRobson
TimRobson replied the topic: X2Pro + Worx4 fail with current FCP XML versions
Can you confirm that you are using the latest version from the app store and is it possible to let us have an xml file which is not processed properly please? If you need the XML to be confidentially handled I can provide an FTP account to upload to but a simple example would be good too.

Please Log in or Create an account to join the conversation.

  • ide3308
  • ide3308's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
3 months 3 weeks ago #8111 by ide3308
ide3308 created the topic: X2Pro + Worx4 fail with current FCP XML versions
Hello, I have seen this question asked before but couldn't find the solution. We are trying to use both apps:

1) X2Pro doesn't respond to v1.10 FCP XML, and returns with an error (Unable to parse) on v1.9. Can't create AAF.
2) Worx4 crashes anytime an XML file is simply selected in file chooser. This happens with v1.10 and v.1.9 XMLs. Can't even try using the app.

We need these apps to work on 4 episodes for a major broadcaster. What are the workarounds to get this to work?

I can attach screenshots or screen recordings.

Please Log in or Create an account to join the conversation.

Time to create page: 0.076 seconds
Powered by Kunena Forum