Missing Channel-Name Metadata after import in ProTools

More
4 months 3 weeks ago #8318 by James Carrick
James Carrick replied the topic: Missing Channel-Name Metadata after import in ProTools
Hi Rakete

The issue is fundamentally that the WAV file is old and there was an original bext or primary method of writing metadata and a additional way later iXML or secondary. We only look in the bext part of the WAV file header, as the spec is tighter on this. We did at the request of Apple implement a change where we would look in the bext for channel name and if none here would then look into the iXML and mirror this in the AAF in both sections. However we had an issue with the release on the App Store in March, where we foolishly decided to remove the product whilst we waited over night for the App Store to qualify the fixed version, but we hit the App Store bureaucracy and it took a couple of weeks before the next version was available. However we had to remove the code changes for 32 bit support and looking in the iXML data.

The next release should have the support for both 32 bit and iXML. If you need both now I can see about getting you a version.

Yours Sincerely

James

Please Log in or Create an account to join the conversation.

  • rakete
  • rakete's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
4 months 3 weeks ago #8315 by rakete
rakete replied the topic: Missing Channel-Name Metadata after import in ProTools
Hey! Thanks for keeping in touch!

We managed to get it working because we found the "Known Issues / Limitations" ( x2pro.net/Pages/known-issues-limitations.html ) Article on your website, Specifically the part: "Track names in Pro Tools are OK but the channel name of the clips is wrong (7116)" wich is exactly the problem we had.

The article is a bit misleading, because it states to import an fcpxml but that's not working.
After copying the audio, we dragged&dropped all the on-set-audio-files to the Sound Devices Wave Agent App, double-clicked in the track-name and then save the resulting files. For every of the hundred files.
We automated this process with a simple script in the App Keyboard Maestro.
Then I reconnected all the new audio files in Final Cut, exported an embedded AAF with x2pro and it worked:
The resulting AAF shows all the metadata in protools (but this destroyed all the 32bit files recorded with a Tentacle Sync TrackE files so we did not use these).

I checked the resulting wave files and the ixml/bwf was rewritten so this did the job.
Maybe this indicated a metadata parsing issue in x2pro?

Please Log in or Create an account to join the conversation.

More
4 months 4 weeks ago #8313 by James Carrick
James Carrick replied the topic: Missing Channel-Name Metadata after import in ProTools
Hi Daniel (rakete)

Daniel B is off this week, just wondering whether you were able to provide a screen shot detailing where one or more of the discrepancies are please.

Many thanks.

James.

Please Log in or Create an account to join the conversation.

More
5 months 3 days ago #8312 by Daniel Beasley
Daniel Beasley replied the topic: Missing Channel-Name Metadata after import in ProTools
Hi Daniel,

I've had a look at your xml file to see if I could spot anything inside it which might be causing any issues, but no luck on that side of things. We need a bit more information on what exactly is missing out of the AAF. If you're able to give a couple examples of named clips and where in the timeline they are that would be helpful :). If you are able to provide screenshots that would be great as well.

Many thanks,

Daniel

Please Log in or Create an account to join the conversation.

  • rakete
  • rakete's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 months 5 days ago - 5 months 4 days ago #8311 by rakete
rakete replied the topic: Missing Channel-Name Metadata after import in ProTools
Hey Daniel :)

Thanks for your fast response.
Sorry I forgot to include the infos right away.

You will find the xml attached and all the infos I can get right here:

My system:
Mac Studio M1 Ultra 128GB
macOS 12.4
Final Cut Pro X 10.6.3
X2Pro Audio Convert 4.5.12

The audio-files are recorded mostly with a SoundDevices Mix688, some with a Tentacle TrackE and a SoundDevices 788T.
The files are poly with 1 to 8 channels, PCM, 24bits, 48kHz. And some 32bit files from the TrackE.

In the sound studio:
ProTools 2020.12 on a Mac
I don't have more info at the moment.

Thanks for your time!
Daniel
Attachments:
Last Edit: 5 months 4 days ago by rakete.

Please Log in or Create an account to join the conversation.

More
5 months 5 days ago #8310 by Daniel Beasley
Daniel Beasley replied the topic: Missing Channel-Name Metadata after import in ProTools
Hi Daniel,

Would you be able to send us the fcpxml file that you are using so I can take a look at what is inside it? Knowing what type of media, what version of FCPX, X2Pro and Pro Tools you are using will be useful as well.

Thanks,
Daniel

Please Log in or Create an account to join the conversation.

  • rakete
  • rakete's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
5 months 5 days ago #8309 by rakete
rakete created the topic: Missing Channel-Name Metadata after import in ProTools
Hello!

I am working on getting the audio for a feature film to the sound studio nut we have a huge problem:
The Channel Names / Metadata are missing after importing to ProTools wich makes it almost unusable.
At our initial tests we found out that x2pro stops to pass the channel names through after some Channels but we could not reproduce.

I can't send you screenshots at the moment but I will try get them asap.
Sorry for the urgency but we need to sort this out as soon as possible :)

Thanks in advance,
Daniel

Please Log in or Create an account to join the conversation.

Time to create page: 0.097 seconds
Powered by Kunena Forum