No AAF created - "referenced asset"

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
2 years 8 months ago #3993 by Jeremy Norwood
Jeremy Norwood replied the topic: No AAF created - "referenced asset"
Your colleague, Mikael Kyster, emailed about sending us a drive with some of your projects on them for us to investigate.
Having looked through your project XML and discussing a few things with the developers, we are going to need your media for this project as well, to be able to determine the cause of these problems.

I wanted to make sure you could put one of these projects on the drive that is being sent to our UK office for us to have a look at.

Many thanks.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #3990 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
Thanks for looking into this.

You are right in that I am making adjustments. Each time I fixed an issue on the timeline causing an error, I exported a new xml. So All errors are from the same project but from different xml's. The attached xml is from the first export, before any adjustments.

What I am doing is
- Export xml of the project.
- Open xml in X2pro* and start.
- Get error, look at "clip starting at" and find that clip in the Final Cut Project.
- 'Detach audio' from the clip and 'reset speed' on the detached audio.
- Rinse and repeat until I have an xml that works.


*My X2pro preferences are
General: 'Discard transitions' & 'Discard disabled clips' are checked.
Media Handling: 'Trim handles', 2 seconds. 'Embed the media, optionally trimming'.
Roles: 'Keep sub-roles separate'.

Please Log in or Create an account to join the conversation.

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
2 years 9 months ago #3989 by Jeremy Norwood
Jeremy Norwood replied the topic: No AAF created - "referenced asset"
Chris,

I am trying to document for our support tracking purposes what exactly is going on with these different error messages, so our developers can get this resolved.

Do all of theses error messages come form the same project XML and how do you get the different error on the same file?
Are you making adjustments to the project based on the original error message and the re-exporting it and getting the other errors?
If you are making adjustments, what adjustments are they?

I know you have mentioned in the past, with regards to this error specifically, that you think this is being caused by re timing on the clips; so i am just trying to pinpoint that and help lead our developers in the right direction to resolve things.

Please let us know your comments with regards to my questions above.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #3988 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
Edited post with exact errors

Please Log in or Create an account to join the conversation.

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
2 years 9 months ago #3987 by Jeremy Norwood
Jeremy Norwood replied the topic: No AAF created - "referenced asset"
Chris,

Can we get the full error message for this please?
That is the only way we can actually look into this.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago - 2 years 9 months ago #3985 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
Yet another round of

Writing AAF file
Adding tracks to AAF file
Writing AAF track structure
Processing clip
Adding clip from source channel 1 to track 4
The clip starting at 308.88 seconds in the project has an end point within its referenced asset [KA_160204_Beautyshots Helikopter_752.4] of 6920 edit units but the asset only has a length of 6460 edit units

No AAF file has been generated.
X2Pro Audio Convert 3.0.13

——————————

Writing AAF file
Adding tracks to AAF file
Writing AAF track structure
Processing clip
Adding clip from source channel 1 to track 4
The clip starting at 894.16 seconds in the project has an end point within its referenced asset [KA_151205 - 2 senil dame eftersøges og findes død af borger + 60 årig selvmordstruet mand eftersøgt dag 2 GoPro 4 Helle_40135.1] of 9320 edit units but the asset only has a length of 7660 edit units

No AAF file has been generated.
X2Pro Audio Convert 3.0.13

——————————

Writing AAF file
Adding tracks to AAF file
Writing AAF track structure
Processing clip
Adding clip from source channel 1 to track 4
The clip starting at 1459.76 seconds in the project has an end point within its referenced asset [KA_160209_Stocks_KARUP HOLDET_0105.1] of 14968 edit units but the asset only has a length of 3600 edit units

No AAF file has been generated.
X2Pro Audio Convert 3.0.13

——————————

Writing AAF file
Adding tracks to AAF file
Writing AAF track structure
Processing clip
Adding clip from source channel 1 to track 12
The clip starting at 2188.92 seconds in the project has an end point within its referenced asset [KA_160128_Eftersøgning ung mand_Randers havn_Lyd_0003.3] of 19479 edit units but the asset only has a length of 18159 edit units

No AAF file has been generated.
X2Pro Audio Convert 3.0.13

——————————

Writing AAF file
Adding tracks to AAF file
Writing AAF track structure
Processing clip
Adding clip from source channel 1 to track 20
The clip starting at 2199.96 seconds in the project has an end point within its referenced asset [KA_160128_Eftersøgning ung mand_Randers havn_Lyd_0003.3] of 10999 edit units but the asset only has a length of 10840 edit units

No AAF file has been generated.

Fcpxml attached.

File Attachment:

File Name: PGM6_X2Pro.fcpxml.zip
File Size:1,459 KB
Attachments:
Last Edit: 2 years 9 months ago by ChrisBee.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #3912 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
Thanks, and you just got an upload

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Offline
  • User is blocked
  • User is blocked
  • X2Pro Support
More
2 years 9 months ago #3911 by Graeme Robinson
Graeme Robinson replied the topic: No AAF created - "referenced asset"
I've sent you an email with FTP details

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation
The following user(s) said Thank You: ChrisBee

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago - 2 years 9 months ago #3910 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
Thanks.

On #2+3 Yes, I know this has been stated previously. And seeing as none of these retimed & reversed clips are not compound clips?

I'd be grateful for that FTP :)
Last Edit: 2 years 9 months ago by ChrisBee.

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Offline
  • User is blocked
  • User is blocked
  • X2Pro Support
More
2 years 9 months ago #3909 by Graeme Robinson
Graeme Robinson replied the topic: No AAF created - "referenced asset"
  1. Yes, I suspect there is something strange with that mp3 file, perhaps corrupted. We are happy to look into it if you can provide the file.
  2. As long as a retiming effect is not done on a compound clip, X2Pro should be ignoring retiming effects on audio and converting the project anyway. It should include the audio at the original speed in the AAF. If it's not doing this and a retimed simple clip causes an error creating the AAF, then it's a bug and we will need to investigate. To investigate, we will need the fcpxml file and the error message that is shown when you try to convert it.
  3. See number 2

I can provide FTP details via email if you would like so that you can upload the files that we need.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation
The following user(s) said Thank You: ChrisBee

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago - 2 years 9 months ago #3908 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
Sorry about being unclear, It made sense in my fevered mind ;)
  1. .mp3 not read properly by X2Pro (corrupt'ish file is my guess?)
  2. Retimed clips without detached audio is not ignored and cancels creation of .aaf
  3. Reversed clips with audio (-100%) also causes X2Pro to cancel .aaf creation

As per a previous post from you guys, I get that retiming is a problem in creating .aaf's as such. But it sure would be nice to just have the .aaf created anyway, either skipping or ignoring the retimed parts (retimed audio is also very unlikely to be used in a final mix anyway - at least with the broadcast I and others I know work with.)

Edit: Apparently I'm unable to send the compressed xml (9,4MB) as attachement here.
Last Edit: 2 years 9 months ago by ChrisBee.

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Offline
  • User is blocked
  • User is blocked
  • X2Pro Support
More
2 years 9 months ago - 2 years 9 months ago #3907 by Graeme Robinson
Graeme Robinson replied the topic: No AAF created - "referenced asset"
It's very hard to understand exactly what problems you are reporting here. When you hit an error can you please make sure that you attach the fcpxml (zipping it first will make it much smaller) and put the full error message in the forum post (like you did in your most recent message).

Regarding your error related to _UPRIGHT_LQC_012_010_Assassination_Attempt_(Alternate_Version):

You're right, the message that says "Does this movie contain an unsupported audio format?" is a little unclear because an MP3 file is not a movie. It should say something like "Does this file contain an unsupported audio format?"

There are no known issues with etracting audio from mp3 files. Are you able to provide the mp3 file so that we can take a look at it to see why X2Pro doesn't like it?

Regarding your error related to insufficient edit units:

Can you please attach your fcpxml (zipped) and include the whole text from the error report.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation
Last Edit: 2 years 9 months ago by Graeme Robinson.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #3905 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
plus this...

Writing AAF file
Adding assets to AAF file
Adding essence for asset [_UPRIGHT_LQC_012_010_Assassination_Attempt_(Alternate_Version)] to AAF file
Adding essence data to AAF file for portion 0 of asset [_UPRIGHT_LQC_012_010_Assassination_Attempt_(Alternate_Version)]
Reading audio data from audio extractor : 649392 samples
Failed to read 649392 samples
Error Extracting audio data (read 851968 bytes of 1298784 required) (Cannot Open)

Suggestion: Does this movie contain an unsupported audio format ?

No AAF file has been generated.
X2Pro Audio Convert 3.0.13

No! That .mp3 is *not* a movie file. The timeline is riddled with mp3's. The others seem to be supported. Wat's this now...

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago - 2 years 9 months ago #3903 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
...sigh... it just never stops.


X2Pro Audio Convert[1426]: *** The clip starting at 546.92 seconds in the project has an end point within its referenced asset [KA_151208 - boarding Jord_6615.2] of 4200 edit units but the asset only has a length of 1800 edit units

Apparently reversed clips -100% will also trip up X2Pro.

Regular speed/slow clips that have not had audio detached and normalized manually *still* an issue.

Why it worked that one time (previous post) is now the mystery, and not why it doesn't. I may have taken an already cleaned up timeline and sent through X2PRO in my tired, stressed out state of mind.

OSX 10.11.4
FCPX 10.2.3
X2PRO 3.0.13
Last Edit: 2 years 9 months ago by ChrisBee.

Please Log in or Create an account to join the conversation.

More
2 years 9 months ago #3865 by ChrisBee
ChrisBee replied the topic: No AAF created - "referenced asset"
.. One more thing..

I had assumed the latest version of Pro Video Formats (2.0.4) was installed. That was not the case.

Please Log in or Create an account to join the conversation.

Time to create page: 0.100 seconds
Powered by Kunena Forum