Roles and Subroles do not show up in X2PRO

More
1 year 7 months ago #5732 by Daniel Beasley
Daniel Beasley replied the topic: Roles and Subroles do not show up in X2PRO
Hi Stephen,

There are three different names used for a clip in the FCPXML. The clip element name, the name used in compound or multicam and the underlying media clip name.
All of these names are valid, but only one of them can be used in the AAF. We used to use the clip element name, but due to popular request we now use the underlying media name.

I hope this explains what you are seeing.

Regards,

Daniel

Please Log in or Create an account to join the conversation.

  • shadesofgraywpg
  • shadesofgraywpg's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Filmmaker, Designer, Developer, Marketer
More
1 year 7 months ago #5731 by shadesofgraywpg
shadesofgraywpg replied the topic: Roles and Subroles do not show up in X2PRO
Hey Daniel - yes that is the same FCPXML file. However, I did resolve this issue a long time ago simply by using 'current version' from FCPX as well as "Audio" (not Extended) when exporting a new file. This seemed to work. The other extended export did not read roles correctly.

Side note: I wish the naming structure was the same as FCPX when converting. Capitalization, spaces, etc. When bringing into Logic-X, for example, a lot of the track names had some extra information in them and missing 1 or 2 words from the original Role Name. I don't know if this is a known issue or not - just speaking from an organizational stand point in working with teams in post production. Having put in the effort of properly naming everything in FCPX, I was hoping that would transfer properly into Logic-X using X2Pro.

Cheers!

Stephen Gray
Filmmaker, At First Sight Films
www.instagram.com/atfirstsight/

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #5729 by Daniel Beasley
Daniel Beasley replied the topic: Roles and Subroles do not show up in X2PRO
Hi Stephen,

We are slightly confused because when we look at your XML in the current release (4.0.29) and the future release (4.0.32) we can clearly see 9 roles compared to the 6 that you are able to see. Please see the attached image, can you confirm that we are using the same FCPXML.

Thanks,

Daniel
Attachments:

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #5719 by James Carrick
James Carrick replied the topic: Roles and Subroles do not show up in X2PRO
Dear Stephen

I have sent you a private mail, we have raised this as ticket 7523, we should support roles and subroles.

Yours sincerely

James

Please Log in or Create an account to join the conversation.

  • shadesofgraywpg
  • shadesofgraywpg's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Filmmaker, Designer, Developer, Marketer
More
1 year 8 months ago #5671 by shadesofgraywpg
shadesofgraywpg replied the topic: Roles and Subroles do not show up in X2PRO
Quick update: I've tried exporting from FCPX as with "latest version" as well as Audio export with XML drop down options, and it seemed to be able to read most of the roles with this. Not all, and some were labelled really differently than what I had assigned within FCPX but it's better than nothing!

Stephen Gray
Filmmaker, At First Sight Films
www.instagram.com/atfirstsight/

Please Log in or Create an account to join the conversation.

  • shadesofgraywpg
  • shadesofgraywpg's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Filmmaker, Designer, Developer, Marketer
More
1 year 8 months ago #5670 by shadesofgraywpg
shadesofgraywpg replied the topic: Roles and Subroles do not show up in X2PRO
I'm experiencing this same issue with missing roles, trying to go from FCPX to Logic-X using X2Pro. All latest versions. Attached XML and screenshot from FCPX and X2Pro for reference & comparison. Moving into post-audio this week so we need to have roles resolved as possible to hit our deadline. Thanks!

Stephen Gray
Filmmaker, At First Sight Films
www.instagram.com/atfirstsight/
Attachments:

Please Log in or Create an account to join the conversation.

More
2 years 2 weeks ago - 2 years 2 weeks ago #5170 by James Carrick
James Carrick replied the topic: Roles and Subroles do not show up in X2PRO
Dear Dan, Ase and Maarten,

We have just released 4.0.17, can you please retry as this should resolve the issue.

Yours sincerely

James
Last Edit: 2 years 2 weeks ago by James Carrick.

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
2 years 1 month ago #5081 by Graeme Robinson
Graeme Robinson replied the topic: Roles and Subroles do not show up in X2PRO
The next version will probably contain the fix but if not, the version after that will. It has gone though development already, but not gone through QA/Test yet. After that it also will need to be approved by Apple before it can be put in the app store.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #5080 by MaartenEC
MaartenEC replied the topic: Roles and Subroles do not show up in X2PRO
Thanks, Graeme! That helps. Do you know when this bug will get fixed?

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
2 years 1 month ago #5079 by Graeme Robinson
Graeme Robinson replied the topic: Roles and Subroles do not show up in X2PRO
Maarten,

There is a bug in X2Pro where clips that are on a secondary storyline inherit the audio configuration from the clip that the secondary storyline is connected to.

All the clips with "Voois Over" assigned as their role are on two secondary storylines that are both attached to the first clip in your sequence. That first clip has had audio channels 1, 2, 5 & 6 disabled and the bug in X2Pro means that the clips on the secondary storylines have also inherited this. Since they only have 1 channel, the whole clip has been disabled.

You can work around this bey changing what clip the secondary storylines that contain the vo clips are attached to. For example CMD+OPT+Click on the secondary storylines at 2:12 to attach them to the second clip in the primary storyline.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago - 2 years 1 month ago #5078 by MaartenEC
MaartenEC replied the topic: Roles and Subroles do not show up in X2PRO
Attached the fcp xml file. Missing role is 'voois over' (voice over).

Thanks!
Last Edit: 2 years 1 month ago by MaartenEC.

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
2 years 1 month ago #5076 by Graeme Robinson
Graeme Robinson replied the topic: Roles and Subroles do not show up in X2PRO
Please attach your fcpxml and tell us what clips and roles are missing.

Please Log in or Create an account to join the conversation.

More
2 years 1 month ago #5075 by MaartenEC
MaartenEC replied the topic: Roles and Subroles do not show up in X2PRO
Hi,

I've got this issue as well. I've made a role 'voice over' and subroles for each language. This role and its subroles won't show up in X2pro. Renaming / reassigning / new roles - nothing helps.

I'm using FCP X 10.3.2 / MacOS 10.12.3 / X2Pro 4.0.12.

Please advise,

Kind regards

Please Log in or Create an account to join the conversation.

  • Jeremy Norwood
  • Jeremy Norwood's Avatar
  • Offline
  • User is blocked
  • User is blocked
More
2 years 2 months ago #4898 by Jeremy Norwood
Jeremy Norwood replied the topic: Roles and Subroles do not show up in X2PRO
The last we heard from you, you explained that you had a workaround but ot a solution to the missing roles problem.
We haven't seen a response to Graeme's post below and I wanted to follow up with you.
Do you have problems with both 1.5 and 1.6 XMLs still?

Please let us know.

  • Please read the forum rules before making a new post.
  • Copy and paste the text from any error message. Please don't post screen grabs of X2Pro error messages.
  • Investigations into issues when converting a project will be faster if you attach your fcpxml file[
  • If you are having trouble with X2Pro's "Media Locations" or the app sandbox, please read this explanation and guide for help.
  • If you seeing the error message "not a WAV file or too many audio channels", please read this explanation .
[/color]

Please Log in or Create an account to join the conversation.

  • Graeme Robinson
  • Graeme Robinson's Avatar
  • Visitor
  • Visitor
2 years 2 months ago #4873 by Graeme Robinson
Graeme Robinson replied the topic: Roles and Subroles do not show up in X2PRO
If you get all the roles, but an error when using the v1.6 fcpxml, perhaps we should look into that. Can you try removing the clip called "018_0005" from your project and try converting a 1.6 fcpxml again?

Please Log in or Create an account to join the conversation.

Time to create page: 0.187 seconds
Powered by Kunena Forum